My bike bogs but if I slowly role the throttle it revs up. If I turn on the choke it doesn't bog and runs perfectly.?

10 Answers

Relevance
  • Anonymous
    4 weeks ago

    Go to any bike shop and tell them.  It takes a mechanic a few minutes with a screwdriver to fix you all up.   Go to the dealer shop that sells that brand of bike.  they are more apt to make sure their machines are running right.

  • fuzzy
    Lv 7
    1 month ago

    obtain a copy of the manual for the bike. Haymes, Clymer or something online.

    Read the section on the carby. Follow the directions. I'd tip partly blocked jet, holed CV diaphram or float level wrong or air leak between carb & engine

  • 1 month ago

    I dont have a air filter on the bike at the moment. But I got one on its way. But still with the old air filter it would do the same problem. And When I'm trying to start off the bike its has NO bottom end power like nothing but then when it hits the powerband it goes. 

    IT is a 2 stroke honda cr80 1998

  • 1 month ago

    Your mixture is too lean.

  • What do you think of the answers? You can sign in to give your opinion on the answer.
  • Fred
    Lv 7
    1 month ago

    You likely have an air leak allowing air to get in after the carbureta such as a cracked rubber block between the carbureta and the engine.  By quickly opening the throttle there is a tendency for the engine to have too much oxygen compared to the fuel and if there is extra air getting in after the carbureta this will make the air fuel mix so lean it struggles with quick acceleration.  By opening the throttle slowly you minimize this leaning of the air/fuel mixture allowing the engine to rev closer to the way it is supposed to just a bit slower to build the revs.  By turning on the choke you are actually riching up the air/fuel mixture and the air to fuel ratio is closer to what it is suppose to be.  

    If I was you I would take off the carbureta and remove the rubber block that it mounts onto and thoroughly check it for a crack which would be letting air in.  Also check where the carbureta mounts into the rubberblock that there is no way the seal between the carburetta and the rubber block is letting air in.

      The old Suzuki ER185 2 stroke dirt bikes of the early 1980s were notorious for the rubber blocks cracking and generally while riding in warm weather they would start to diesel where you turn the ignition off and the motor would still keep running and the only way to stop them beside turning the fuel off and waiting was to raise the seat and block the air cleaner so it could not suck air and pick up any fuel through the carbureta to keep the motor running.

      Check the rubber block out as likely it is where the air is getting in after the carbureta.  My belief is it has cracked or torn through old age and heat and needs replacing.

  • Bill
    Lv 7
    1 month ago

    Sounds like your carburetor is out of adjustment.

  • adam
    Lv 5
    1 month ago

    its running lean. Has it been sitting for a long period of time? Causes could be the gas is turning bad and fouling the pilot jet or jets if more than one carb. Or a manifold leak. Spray some WD40 around the manifolds while its running and see if the idle RPM changes. If no change then you need to dissasemble and clean the carb [carbs] . Do not use seafoam. Its not going to clean out a clogged pilot jet. 

  • David
    Lv 4
    1 month ago

    It has a very lean air to fuel ratio. Check the pilot jets. Check for intake manifold leaks. Also, if it is a 4 stroke, check the valve clearances, a tight vale can cause a lean condition.

  • CB
    Lv 7
    1 month ago

    Run some seafoam through it, change the fuel filters, and try again. If still a problem then start tearingshit apart.  Also check the air filter and boot from air filter box to the carb(s).

  • arther
    Lv 5
    1 month ago

    as it runs ok with the choke on the air fuel mix must be too lean. Air leak between carby and motor? 

Still have questions? Get answers by asking now.