SMOK Nord pod and coil recognized but blinking 4 times (not firing)?

Hey. My nord was working just fine but I went to change the coil and it suddenly wasn't firing. The pod still blinked once when I put it in so it was recognizing it, but it would blink 4 times when I tried to use it. I know it isn't the coil, because I put the old coil (the one that previously worked) in and it didn't work with that either. I've taken the nord apart before so if it comes to that, I don't mind it. The prongs are fine and I've pretty much tried everything. The coil is in the correct way, there isn't any juice in the mod or around the coil, I pulled out the circular golden part of the coil, I've done everything. It's really frustrating. I just don't know what I would do to get it to fire, but I'd like to repeat that I know it's being recognized. Any and all responses are appreciated, thanks <3

1 Answer

  • 8 months ago

    Why would this be posted in the Jeep section?

    • Eric8 months agoReport


    • Commenter avatarLog in to reply to the answers
Still have questions? Get answers by asking now.